QuickBooks 2015 System Requirements 2


Quickbooks 2015

Regarding all the questions I get about QuickBooks 2015 requirements; if you plan to move to QuickBooks 2015, it’s time for you to upgrade from XP to a new operating system. However, if you plan to stick with QuickBooks 2014 for awhile, consider that currently, all versions of QuickBooks 2014 support installation on XP Pro Service Pack 3. Check this link: http://support.quickbooks.intuit.com/support/articles/INF24382.

Although Microsoft no longer supports XP, by using a modern version browser, not Internet Explorer 8 and by using updated security software, one can mitigate most of XP’s security problems. No Microsoft support for XP Pro means very little, as refurbished XP Pro desktops will be around for some time to come.

The Painless QuickBooks XP Pro based QuickBooks Production Server still proves itself to be the easiest to configure and most cost effective way to host QuickBooks company files to Windows 7 or 8 client computers running any version of QuickBooks 2014 or earlier, sized for five users or less.

When you’re ready for QuickBooks 2015, return to painlessquickbooks.com and review these QuickBooks 2015 system requirements direct from Intuit QuickBooks Support at http://support.quickbooks.intuit.com/support/articles/inf26865 are listed below.

Pay particular attention to “natively installed,” performance issues with QuickBooks on RAID arrays and Microsoft Office 365 issues.

Operating systems:

Operating systems supported:

Windows 8, all editions including 64-bit, natively installed
Windows 7, all editions including 64-bit, natively installed
Windows Vista (SP1 or later), all editions including 64-bit, natively installed
Windows Server 2012, Windows Small Business Server 2011, Small Business Server 2008
Windows Server 2008 R2, Windows Server 2008, and Windows Server 2003 (SP2), including 64-bit, natively installed

Database Servers:

Windows: natively installed & Windows 8, Windows 7 or Vista (SP1) with UAC on, Windows Server 2011, Windows Server 2008 R2, Windows Server 2008, Windows Server 2008 – Terminal Server Config., Windows Server 2003 (SP2), and Windows Small Business Server 2008

Note: Windows Home Server Edition is not supported.

Hardware and operating system requirements (client and server)

2.4 GHz processor minimum
System processor should support at least Streaming SIMD Extensions 2 (SSE2) instruction set
2 GB RAM minimum

RAM requirements for multi-user setup
5 users: 2-3 GB
10 users: 3-4 GB
15 users: 4-6 GB
20 users: 6-8 GB

4x CD-ROM drive required for CD installations

Display optimized for 1024 x 768 screen resolution or higher with up to 2 Extended monitors

Best optimized for Default DPI setting (96 DPI or 100%). Additionally, medium DPI (120 DPI or 110%) is supported to ensure an optimal experience for 110% scaling.

Windows:
U.S. version
Regional Settings are supported when set to English (United States) with keyboard setting to U.S. only
Administrator Rights required for the server computer when hosting Multi User Access
Natively installed

Disk space requirements:
1.5 GB of disk space (additional space required for data files)
Additional software: 250 MB for Microsoft .NET 4.0 Runtime, provided on the QuickBooks CD
Additional requirements for Intuit Data Protect in QuickBooks Connected Services offerings
Require minimum 2.0 GB Ram
Twice the size of the largest File set to back up + 100MB or twice the size to restore. The space is only required from the work folder LocalApplicationData+”Intuit\Intuit Data Protect”

Software compatibility:

QuickBooks is capable of integrating with hundreds of third-party applications. The following integrations are provided with QuickBooks; additional RAM will enhance the use of these features. See Intuit Marketplace for the most up-to-date list.

Microsoft Office:

Office 2010 and Office 2013/365 (including Outlook 2010 and Outlook 2013) both on 32 and 64 bit. (Note: Office 365 is only supported when it is locally installed, not the web version.)
Preparing letters requires Microsoft Word 2013, 2010, or 2007.
Exporting reports requires Microsoft Excel 2013, 2010, or 2007.
Contact Synchronization with Microsoft Outlook requires Outlook 2013, 2010, or 2007.
Synchronization with Outlook requires QuickBooks Contact Sync for Outlook (the download is available at no charge).
Contact Sync does not work with the Microsoft Business Contact Manager Outlook plug-in. If a sync is performed, duplicate records could result

QuickBooks Point of Sale 2015 (V12.0), V11.0 , V10.0

Adobe Acrobat Reader: Business Planner functionality and viewing forms requires Adobe Acrobat Reader 5.0 or later.

Payroll and other online features and services requires Internet access with at least a 56 Kbps connection speed (DSL or cable modem recommended)
TurboTax 2014 and 2013 (Personal and Business)
Lacerte 2014 and 2013
Pro-Series tax years 2014 and 2013
QuickBooks for Mac 2015
Quicken 2015, 2014, 2013
Gmail, Yahoo Email, Windows Mail, Hotmail and AOL
Internet Explorer 11, 10, and 9.
Firewall and antivirus software compatibility
QuickBooks Pro 2015 has been tested with the following firewall and antivirus products.

Note: In some cases, it may be necessary to adjust settings in these products to ensure the best possible performance with QuickBooks.

Windows Server Firewall (all editions)
Windows 8 and 8.1 Firewall (all editions)
Windows 7 Firewall (all editions)
Windows Vista Firewall (all editions)
Microsoft Security Essentials
Avast
Windows Defender
AVG
Symantec
ESET
Avira
Kaspersky
McAfee
Bitdefender
Norton

Note: QuickBooks will work with systems running RAID (Redundant Array of Inexpensive Disks) but this is not recommended because performance issues may cause QuickBooks to operate slowly.


2 thoughts on “QuickBooks 2015 System Requirements

  • Pete Kremer

    Thanks for this wealth of information; well done. If one has updated to Windows 10, it would appear that there exists a problem in that Quickbooks may not yet be ready for this new system. If that’s correct, what would be a good solution? Thanks in advance.

    • Les Murphy Post author

      If you’ve already updated, stick with Windows 10. If some QuickBooks functionality does not work, check QuickBooks support and QuickBooks Community for answers to fix or work around the problem. If the issues are so bad that you cannot work with them, get another computer, Win 8.1 or earlier, install your version of QuickBooks then recover a current backup to your new computer and go back to work.

      If you have not updated to Windows 10, wait until Intuit puts Windows 10 on the list of supported operating systems. Check the requirements at http://support.quickbooks.intuit.com/Support/Articles/INF28307

Comments are closed.